Twitter Updates 2.2.1: FeedWitter

Thursday, March 29, 2007

OneJava or NoJava or TwoJava for JavaME/CDC1.1?

I waiting and waiting for devices supporting JavaME/CDC1.1/FP1.1/PP1.1 and AGUI!

Last year at JavaOne something happen, the Java based phone "Jasper" from Savaje was released and I suddenly was able to buy me phone that support JavaME/CDC1.1!! But last year in November the company SavaJe was out of buissness and again no phone on the market was supporting JavaME/CDC1.1/FP1.1/PP1.1 and AGUI!

I think that this sort of problem (with badly support of JavaME/CDC in devices) we perhaps can avoid because JavaME is Open Source, this really something great that have happen during 2007!!

There is also a other interesting JavaME/CDC1.1 solution from a Eclipse project called eRCP. eRCP is installed on top of JavaME/CDC1.1/FP1.1 and using eSWT instead of AGUI. eRCP 1.0.1 is already released and the release plan (I think I don't know) for eRCP look like this: Release 1.0.2 April 2007, Release 1.1 July 2007.
Today the eRCP project is supporting following platforms:
  • OS: Windows, CPU: x86
  • OS: Windows Mobile 2003 & 2005,CPU: ARM,x86(?)
  • OS: Nokia Series 80,CPU: ARM
Other platforms that work is going on to add support for eRCP:
  • OS: Nokia Series 60, CPU: ARM
  • OS: Linux Qte, CPU: ??
  • OS: Windows CE v5.0, CPU: ARM
Anyone know more about future plans for devices supporting JavaME/CDC1.1/FP1.1/PP1.1 or eRCP?
Please tell me!!
I hope they release something during JavaOne!
It is now only 39 days left to JavaOne!!

2 comments:

R. Varttinen said...

I think the Sony Ericsson P990 and M600 devices support CDC 1.1.

Check out: http://developer.sonyericsson.com/getDocument.do?docId=77003

Ove Nordström said...

I think Sony Ericsson P990 and M600 devices support:
Java ME CDC 1.0
Foundation Profile 1.0
Personal Profile 1.0